Vodafone UK Business Broadband with the DrayTek Vigor 130 + OpenWrt

Image for post
Image for post

I recently decided that I would get a second fixed broadband line in addition to my existing broadband connection, given my increased working from home pattern per recent world events. Shopping around I found Vodafone Business Broadband a cheap and decent enough package. I decided to go with their Superfast 2 option. This article is intending to be useful for other customers who use Vodafone VDSL but decided they want to bring their own modem to party!

Bringing your own modem (BYOM)

You don’t have to do this, but for my usage and purposes, the Vodafone WiFI Hub (aka the THG3000) isn’t going to cut it, because it lacks any form of bridge mode/modem mode. Regardless I got one anyway. Unfortunately, ever since BT stopped providing and supporting VDSL modems a while ago, the ISPs have had to fill this gap and it’s often the case that such kit is a router/modem combined. Already having an established network setup with an OpenWrt router, I don’t need another router doing NAT, I just want a WAN connection I can hook into an existing router directly, where I can do failover configuration.

Fortunately, Vodafone is fairly relaxed about using your own modem. The main thing is to ensure it is BT SIN 498 MCT approved. While there isn’t an official list, there are various lists around that mention various third party modems. I chose to use the DrayTek Vigor 130, it has good reviews, it’s literally just a modem with a single ethernet port for the VDSL passthrough and that’s it. Just what I need for this.

Vodafone PPPoE credentials

Vodafone UK uses PPPoE to connect to their broadband network, which requires a username and password. In the earlier days it sounded like customers had trouble getting this information from Vodafone. However, within the first few days of ordering their Superfast 2 business broadband I received an email with my PPPoE username and password without any prompt, so credit to Vodafone here (I don’t know if this is exclusive to business lines though). One thing they should make clear though is for some reason, they have decided to have the username in the email without the ending suffix of either broadband.vodafone.co.ukor businessbroadband.vodafone.co.uk. They do reference the importance of this in the email beforehand (shown below), but sometimes as humans we don’t read things properly and I think there’s a been a lot of users just copying the username without this and having problems. Ideally, the dynamic data in their email template should be concatenating the username and the appropriate suffix as as single string on one line to be very clear here, as it is important!

Vodafone should also fix the typo in their automated email as they are telling users that they should put “@broadband@vodafone.co.uk”, which is plain wrong. Fortunately, at least OpenWrt contributors have made this clear for the username and password format for Vodafone UK broadband lines.

Image for post
Image for post
Vodafone email with PPPoE instructions, where the consumer broadband suffix is incorrect.

Getting connected

My residence was pre-wired with a BT line when it was first built back in 2006, but an engineer was automatically assigned to my activation date upon ordering. It turns out Openreach’s system had flagged something on the line. Speaking with the Openreach engineer on the day (who was really friendly and I made sure Openreach knew this through their thank an engineer form), this was due to a HR fault (high resistance, not human resources!). In the end I had my master socket front plate replaced with the NTE5C + Mk4 Faceplate, so no DSL filter needed anymore.

The DrayTek Vigor 130, is pretty much setup from powering it on, it has the default IP of 192.168.2.1, which can be changed if needed. In fact you don’t have to change anything, the modem is already in bridge mode.

I did read that a few people suggested enabling MPoA but I can confirm this is not needed at all. I’m not sure if the UK variant has been specifically configured like this by default.

The required VLAN tag of 101 is already set too.

Image for post
Image for post
VLAN tag of 101 is already set within Internet Access > General Setup

Other than changing the default password (which is a good idea as the default is “admin”) and optionally disabling the DHCP server, because it won’t be needed, the only thing to do is plug the DSL connection into the modem and then have an ethernet cable going from the modem into a router. In my case this is going into one of the LAN ports repurposed as a WAN interface by creating a VLAN on my Linksys WRT3200ACM.

Image for post
Image for post
VLAN configuration for having a LAN port as a WAN interface

There’s a couple of new interfaces network within OpenWrt you will want to setup.

Accessing the modem

OpenWrt has information on accessing your modem for a variety of cases. In the case of PPPoE it is quite straight forward.

Whatever interface your modem is connected to (in my case eth0.4), create a new modem interface within /etc/config/network with a static IP within the network range of the modem. Because the Vigor 130 uses 192.168.2.0/24, I have a static IP on the router as 192.168.2.2.

config interface 'vigormodem'
option proto 'static'
option ipaddr '192.168.2.2'
option netmask '255.255.255.0'
option ifname 'eth0.4'

Then you can assign the modem interface to WAN zone. You could have a dedicated zone for modems, but then you need to enable interzone forwarding but this will work for the requirements just as well.

Now you can access you modem at all times on the network. While you won’t really be doing too much with the modem as it is simply passing through the VDSL connection, it is useful for being able to check your sync speeds and get more verbose VDSL information. In the case of the Vigor 130 you can use commands like vdsl status which can be entered through the web UI or SSH. If accessing via SSH, you may have to specify the specific host key algorithm as only ssh-dss is offered, which is considered legacy now. This will however allow you to connect via SSH.

ssh -oHostKeyAlgorithms=+ssh-dss admin@192.168.2.1

Creating the PPPoE interface

You will then need to create a PPPoE interface for the actual VDSL connection being passed through over ethernet.

config interface 'wanb'
option proto 'pppoe'
option ifname 'eth0.4'
option peerdns '0'
option metric '20'
option ipv6 '1'
option username 'xxxxxxxxxxxx'
option password 'xxxxxxxxxxxxx'

Remembering to use the correct username format as per the PPPoE information mentioned earlier!

In my case, I have configured the interface as wanb, as this is an additional internet connection. I will then use mwan3 to do failover if my main internet connection goes down, VDSL can take over. That’s all that’s needed for the PPPoE connection itself. Because I’m on the business broadband line, I have a static IPv4, so I’ll always get the same public IPv4 address. All of the VLAN tag stuff is on the modem side, so we don’t have to worry about that, as we aren’t using a DSL router.

Vodafone currently doesn’t have IPv6 enabled on their broadband network but you can leave it enabled if you want, it won’t harm anything (Other than syslog spam with a DHCPv6 permission denied error). I’ve configured an additional alias interface, in the event Vodafone suddenly does go live with it, as I’m all about that IPv6 life. Taking a reasonable guess, it will be likely that you can use DHCPv6 to perform a router solicitation to request a prefix over the PPPoE connection. This is often the case with PPP based connections.

config interface 'wanb6'
option proto 'dhcpv6'
option ifname '@wanb'
option reqaddress 'try'
option metric '2'
option reqprefix '48'

It is currently unknown when Vodafone UK will go live with their IPv6 deployment. It was rumoured to be in Spring 2020, but due to current world events, this could have been delayed. There has been reports from some customers in 2019 and earlier in 2020 noticing at various times Vodafone did seem to be enabling IPv6 on the network but it seemed to be inconsistent and unreliable, so it may not have been a proper rollout, although very brave testing IPv6 on the live network Vodafone!

Sync speeds

Looking at the BT Broadband availability checker it states the maximum of 80 Mbps is available downstream with a maximum of 20 Mbps upstream through FTTC. However, getting this is based on a few factors.

Image for post
Image for post
BT broadband availability in my area

My average quoted speed from Vodafone is 63 Mbps. Despite what you might read, VDSL does not have a training period (which I mistakenly believed to be the case at first). This is actually only applicable to ADSL (and if you are still stuck on ADSL, my condolences). There is something called Dynamic Line Management (DLM) which is constantly running on VDSL lines to ensure they are performing as best they can while keeping lines within specifications. What can happen though is within the initial period of the line being enabled and connected, DLM may be adjusting your line to find a good profile, so speeds can change, for better or for worse.

On my first sync I was getting around 55 Mbps downstream and 20 Mbps upstream. After a couple of days of my modem being connected, I noticed my downstream had increased to 64 Mbps, which I’m pretty sure was going to be my maximum downstream speed. Looking at the modem stats, this seems to be the case.

> vdsl status---------------------- ATU-R Info (hw: annex A, f/w: annex A/B/C) -----------
Running Mode : 17A State : SHOWTIME
DS Actual Rate : 64336000 bps US Actual Rate : 20000000 bps
DS Attainable Rate : 64449832 bps US Attainable Rate : 23533040 bps
DS Path Mode : Fast US Path Mode : Fast
DS Interleave Depth : 1 US Interleave Depth : 1
NE Current Attenuation : 13 dB Cur SNR Margin : 6 dB
DS actual PSD : 0. 3 dB US actual PSD : 0. 5 dB
NE CRC Count : 2 FE CRC Count : 134
NE ES Count : 2 FE ES Count : 88
Xdsl Reset Times : 0 Xdsl Link Times : 1
ITU Version[0] : fe004452 ITU Version[1] : 41590000
VDSL Firmware Version : 05-07-06-0D-01-07 [with Vectoring support]
Power Management Mode : DSL_G997_PMS_L0
Test Mode : DISABLE
-------------------------------- ATU-C Info ---------------------------------
Far Current Attenuation : 11 dB Far SNR Margin : 7 dB
CO ITU Version[0] : b5004946 CO ITU Version[1] : 544eb206
DSLAM CHIPSET VENDOR : < IFTN >
>

Given my downstream rate and attainable rate are very close, it suggests this is the downstream speed I will be getting.

Looking at the DSLAM Chipset vendor info, it also reveals I’m connecting to an ECI cabinet, which I’ve read can mean slower speeds in some cases compared to some of the Huawei cabinets. This is due to a technology known as G.Inp being deployed in Huawei cabinets as well retransmission (an improved error correction method) that can help increase speeds too. It seems that this it is not used on ECI cabinets because Openreach haven’t really ever got it working well according to various sources.

I did come across some information about the DrayTek Vigor 130 having an alternative firmware build which could potentially lead to better speeds under ECI cabinets. Curious, I ended up testing this by flashing the alternative firmware build. My sync under the alternative firmware was 65 Mbps, a whopping 1 Mbps more, so really not that much gain. I’m also not sure how recommended it is to run the alternative firmware, DrayTek themselves suggest the default BT build for most, so I’ve decided to reflash back and leave it on the default firmware.

I then came across an interesting post on overclockers.co.uk which shows adjusting the SNR (Signal-to-noise) delta on the Vigor 130 can improve downstream speeds (apparently benefiting those connecting to ECI cabinets). I decided to test it out. The poster suggests setting the margin delta to -50, which you can do with vdsl snr -50 , this will then reboot the modem. You can then run vdsl snr without any parameters to confirm the set value.

> vdsl snrUsage:
vdsl snr [delta]
delta: SNR margin delta. The SNR margin delta should range from -50 to 50.
delta=1 means 0.1dB.
Current VDSL SNR Margin is 1 dB.
Current VDSL SNR Margin delta setting is -50.

To my surprise, after a reboot the downstream significantly improved! Syncing at the maximum available (well 5000 bps shy, but close enough!)

> vdsl status---------------------- ATU-R Info (hw: annex A, f/w: annex A/B/C) -----------
Running Mode : 17A State : SHOWTIME
DS Actual Rate : 79995000 bps US Actual Rate : 20000000 bps
DS Attainable Rate : 82568328 bps US Attainable Rate : 24143688 bps
DS Path Mode : Fast US Path Mode : Fast
DS Interleave Depth : 1 US Interleave Depth : 1
NE Current Attenuation : 13 dB Cur SNR Margin : 1 dB
DS actual PSD : 1. 6 dB US actual PSD : 1. 7 dB
NE CRC Count : 24 FE CRC Count : 139
NE ES Count : 24 FE ES Count : 93
Xdsl Reset Times : 0 Xdsl Link Times : 2
ITU Version[0] : fe004452 ITU Version[1] : 41590000
VDSL Firmware Version : 05-07-06-0D-01-07 [with Vectoring support]
Power Management Mode : DSL_G997_PMS_L0
Test Mode : DISABLE
-------------------------------- ATU-C Info ---------------------------------
Far Current Attenuation : 11 dB Far SNR Margin : 9 dB
CO ITU Version[0] : b5004946 CO ITU Version[1] : 544eb206
DSLAM CHIPSET VENDOR : < IFTN >

I’m not an expert with VDSL, so I don’t know the exact issues or all the potential ramifications of this change. I do know it could potentially cause stability issues i.e. increased error count, so I’ve left the modem with these settings for a while to find out. After a couple of days my downstream sync speeds had gone down to 73 Mbps with a SNR value of 3dB, so it would appear DLM may have invoked a change and possible banded my connection.

I was able to get this speedtest result before DLM has kicked in.

Image for post
Image for post
Vodafone speedtest results. 74.1 Mbit/s down and 19.5 Mbit/s up, with a ping of 16.0 ms with an SNR value of 1dB

Now it would appear, it is slightly lower, with the adjustments but overall still better than my original sync. If it can stay within these specifications, I think I’ll call that a success!

Image for post
Image for post

Conclusion

Given my tech interests and background, it is surprising this is my first proper venture into VDSL. Growing up I had dial up, but my parents then went straight to cable broadband (anyone remember NTL?!), so I never really saw ADSL/VDSL much in the household. It was interesting to go hands on with something that’s still probably the most common type of internet connection today. That is until the whole of the UK goes FTTP, but that’s going to take a while. Gigabit Britain, is not happening overnight, but it can’t come soon enough!

I'm a web developer, but also like writing about technical networking and security related topics, because I'm a massive nerd!

Get the Medium app

A button that says 'Download on the App Store', and if clicked it will lead you to the iOS App store
A button that says 'Get it on, Google Play', and if clicked it will lead you to the Google Play store